Quick Tutorial: Gradient Strokes

After reading Lensco's comment "Cool tip, all we need now are gradients on strokes. Pretty please, Adobe?" on the previous tutorial Quick Tutorial: Adding Gradients to Text, I decided to write a quick tutorial about how I create gradient strokes. This super simple technique use the Appearance panel and effects to create editable gradient strokes in Illustrator.

The Problem

In Illustrator, you can't apply a gradient to strokes the way you normally apply gradients to other objects. You can create a stroke on an object, go Object > Path > Outline Stroke, and then fill the stroke with a gradient, but you won’t be able to change the stroke weight later on. Moreover, you can’t use the Outline Stroke method on type while keeping the text still editable. With the following technique, you will be able to add gradient strokes to objects and text while keeping them still editable!

Adding Gradient Strokes to Objects

First let’s go over the steps for adding a gradient stroke to objects. I will go over adding gradient strokes to text following these steps because of the added extra steps when working with text.

Step 1

Select your object with the Selection tool, in my case an ellipse, and make sure it has no stroke applied. With the object selected, open the Appearance panel menu (top left menu button) in the Appearance panel and choose New Fill. Now you should see two fills in the Appearance panel.
Step 2

Select the last fill in the Appearance panel and go Effect > Path > Offset Path and enter the size you want your stroke. You can use px, pts, or whatever you normally use for your stroke weight.
Step 3
Now you can change the offset fill to a gradient and you're done! The great part about using this technique is you can go to your Appearance panel, select the Offset, and change the Offset just like changing the stroke weight!

Adding Gradient Strokes to Text
Creating gradient strokes for text while keeping the text still editable, is similar to the steps above, but with a couple extra steps.

http://vectips.com/tutorials/quick-tutorial-gradient-strokes/
Step 1
Create some text with the Type tool, with the font of your choosing. I am using my favorite font of the moment, Klavika Bold Condensed, just like in the previous tutorial Quick Tutorial: Adding Gradients to Text.

Type Text with Type Tool

Step 2
Set the fill and stroke of your text to none. If you don't this, after you have applied new fills to the text in the following steps, you will sometimes see the original text color peeking out on the text edges.

No Fill and No Stroke

Step 3
Select the text with the Selection tool, open the Appearance panel menu (top left menu button) in the Appearance panel and choose New Fill. Once you have added a new fill, do it one more time, so you have a total of two fills in the Appearance panel.
Step 4

Select the last fill in the Appearance panel and go Effect > Path > Offset Path and enter the size you want your stroke. You can use px, pts, or whatever you normally use for your stroke weight.
Step 5

Now you can change the offset fill to a gradient and your done! Just like in the previous steps, you can change the stroke width (really not a stroke but an offset) as desired and you can also still edit the text!
Change fill to Gradient

Select Offset Path to change Stroke Width

Text Still Editable

Experiment
I hope this quick tutorial makes some of you want to look into the Appearance panel more! It is quickly becoming my favorite panel because of the speed and flexibility it creates when working with Illustrator. I suggest everyone play around with the Appearance panel to see what they come up with! Below is an example type treatment with multiple transparent gradient strokes.
103 Responses to “Quick Tutorial: Gradient Strokes”

February 12, 2009 at 3:01 pm
Kate Garchinsky

This is really handy. Thanks for posting it!

Reply

January 14, 2010 at 6:03 am
Krapster

“Your done” is not English. It’s called “You’re done”

Reply

January 14, 2010 at 7:06 am
Rype

Whoops! Thanks for keeping me on my toes. I’m better at Illustrator than grammar.

Reply

September 28, 2010 at 7:51 am
Jimbob

What’s ‘called’ “You’re done” exactly? The phrase “You’re done”?

“What’s that phrase called? Ah yes, ‘You’re done’, that’s what it’s called.”

You’re an idiot. Next time, make sure you have even the feeblest grasp of English before you criticise others’ use of it.

And yes I know, my post if full of grammatical errors. I have no idea how it all works.

Reply

February 12, 2009 at 3:03 pm
Esben Thomsen

and of course another little bonus is that it can be applied as graphic style.

Reply
February 12, 2009 at 3:04 pm
Ryan this is AWESOME! I've always used Offset Path to create my stroked type, but 1) I didn't know it could be an effect (I love Effects and the Appearances panel; I use that combo for rounded corners too!) 2) can't edit a normal offset path like I used to do 😊

Reply

LaurenMarie - Creative Curio

February 12, 2009 at 3:13 pm
Ohh I wish I had thought this up on my own sooner, and saved a lot of time and effort!

Reply

SundancerSEM

February 12, 2009 at 8:42 pm
Very cool. Different from the way I currently do things, but this seems a bit more intuitive.

Reply

Oscar

February 12, 2009 at 9:47 pm
Good tip always its so amazing

Reply

woofer

February 13, 2009 at 1:01 am
I've been looking for such a tutorial for quiet a while, so thanks a lot, Ryan.

Keep them coming…

Reply

dalia

February 13, 2009 at 2:04 am
Wow, impressed with your quick solution! Until Adobe adds real gradients to strokes, this will do. Thanks.

Also, I need to upgrade to Illustrator CS4, if only for the new gradients tools and the appearance palette.

Reply

Lensco
February 13, 2009 at 7:27 am
Really great tutorial

Reply

devlim.com

February 13, 2009 at 12:37 pm
Simple and great tutorial. No doubt, I'll be using this in the future.
Thanks!

Reply

Mr. Smith

February 16, 2009 at 11:15 pm
So, for me, following the steps above, created a copy of the shape. I then for the life of me could not figure out why – when I changed the fill to a gradient – I couldn't see it. For me I ended up with a smaller top shape that had fill stroke fill (like in your example) where the fills where the same colour. I also had a larger (offset) shape below with fill shape fill (like in the example). I then had to select the top fill of the bottom shape then apply the gradient to get effect. I can also move both shapes independently of each other. So how is this any different then copying the shape and applying a gradient? Or am I not understanding something?

Reply

Chris Shaddock

February 17, 2009 at 6:59 am
@ Chris,
You shouldn't be able to move the object independent of each other when using this technique, I wonder why this could be? Sounds like you are using the Appearance panel, and I am assuming you are applying the New Fill to just one object. The only thing I saw in your description that was different than the lesson is that you need to apply the gradient to the last fill in the Appearance panel.
The place were it might have gotten mixed up, is when you applied the offset effect.
Make sure you have the last fill in the Appearance panel selected when you apply the offset, otherwise the offset effect will create a new shape.
The real power of this techniques is being able to later adjust the offset, like being able to adjust a Stroke weight.
Let me know if that helps at all.

Reply

Rype
February 17, 2009 at 10:46 am

Hey, So I made a quick little screen cast of what I am doing in illustrator.
I posted it on YT here.

Lets hope that link worked.

Chris Shaddock

February 17, 2009 at 11:04 am

@ Chris,

I see where the trouble is. When you apply the Offset instead of going
Object > Path > Offset, Go Effect > Path > Offset.

Let me know if that works.

Rype

February 17, 2009 at 11:57 am

WOOT! It worked. All because I can't read the instructions properly.
Thanks for the patients and the time. Love the site.

Chris Shaddock

February 19, 2009 at 6:51 am

awesome tip once again! Oh how I love the appearance panel

Gen Kazak

February 19, 2009 at 6:51 am

awesome tip once again! Oh how I love the appearance panel

Gen Kazak

February 26, 2009 at 10:30 pm

wow thanks very much for this, amazing as always! ^_^
February 28, 2009 at 10:31 am
Awesome! This can really help in my work! If I knew a few days ago that this was possible, could have saved much time!
Thank you very much! This is only one more reason to love your work: awesome and very usefull, and I love it!
Congratulations!...

Oscar Marcelo

February 28, 2009 at 5:27 pm
thank you verry much for this tuts

yass

February 28, 2009 at 11:40 pm
Really nice look, thanks

T-Law

March 1, 2009 at 2:33 pm
On your example the outer stroke seems colorful and transparent at the same time. My problem is that it becomes (actually seems) gray when it has low opacity. 😞
Where is the mistake?

bars

March 2, 2009 at 10:37 am
@Bars,
Are you changing the opacity on the object or in the Color Stops on the gradient in the gradient panel?

Rype

March 2, 2009 at 4:04 pm
I wonder how you fixed your effects in your example, it seems like that you have an different offset path for every individual letter, how did you do this?
p.s. thanks for the tutorial, helped me a lot =)

Bateman
March 2, 2009 at 4:06 pm

Hi Ryan,

Nice tut,

i am having the same problem as Bars, maybe it's the version of illustrator that i'm using (CS2)? but i can't seem to gain control of gradient transparency/ opacity

Reply

March 2, 2009 at 4:25 pm

@ Danny

Yeah, I think it is because you are using CS2. In the example, I changed the opacity in the gradients not the opacity of the overall text.

Reply

March 2, 2009 at 4:28 pm

@ Bateman

I actually just changed the offset for each individual fill in the Appearance panel. If you look at the Appearance panel in the example, I have a couple of other fills. These other fills I just set a larger offset than the previous one.

Let me know if that helps!

Reply

March 2, 2009 at 5:14 pm

ok, and than you use the transparency panel for each added fill? if i do that, they change to grey, and yours look like transparent.and you can see the offset path trough the order offset for eact letter. how did you fixed that?

Reply

April 4, 2009 at 5:20 pm

make sure your document colour settings are set to RGB, not CMYK.

Reply

March 2, 2009 at 5:30 pm

@Bateman

I applied the transparency to the Color Stops in the gradient (the gradient swatches) from the Gradient panel. You will need CS4 for transparencies.
in gradients. Below is a link to an image with the Gradient panel open to see what it looks like.

Reply

March 3, 2009 at 4:02 am

alright, I think the problem is that I’m working in CS3, better get CS4, thanks for the help!

Reply

Bateman

March 3, 2009 at 4:19 pm

Could you tell me the name of the font you used to label the instructions in your screenshots?

i.e. the font used for “Select Second Fill”

Thanks!

Reply

JSand4325

March 3, 2009 at 4:45 pm

@ JSand4325

I used Fertigo
http://www.josbuivenga.demon.nl/fertigo.html

Reply

Rype

March 3, 2009 at 9:04 pm

thanks again!

Reply

JSand4325

March 10, 2009 at 6:32 pm

Excellent post!

Reply

Jim
Heyki

March 18, 2009 at 4:29 am

good tutorial!

thanks~

Reply

Bateman

March 25, 2009 at 3:25 am

dear rype,

on the website of tutsplus you gave an tut about text effects, you give an
tutorial about making text in an green leave content. You also draw an
ladybug in this tutorial, however when i try to intersect the dots with the
original ellipse i get the message that cs4 can't intersect the dots with the
original ellipse because they ain't overlapping paths. How can i fix this?

Reply

Rype

March 25, 2009 at 4:52 am

This caught me off guard when I started using the new CS4. Try
holding the Option/Alt key when Intersecting. This will make the
Pathfinder not automatically expand when you Intersect. Let me
know if that helps.

Reply

Bateman

March 25, 2009 at 5:41 am

if I hold down the alt/option key my dots dissapear. but should i
copy an paste in front the original ellipse form as in the red
e ellipse, or does this also include the shiny effect? i tried several
different time but it ain't working, help!

Reply

Rype

March 25, 2009 at 8:01 am

Just copy and paste the original ellipse, make sure all the dots
are Grouped together before you Intersect them while holding
down the Option / ALT key. Let me know if that works any better

Reply

Bateman

March 25, 2009 at 8:12 am

that helped! finally, i'm kinda new in working with CS4 and there is one
more question remaining( i know it's getting annoying isn't it?) i also had
problems with this when making the tut about your reflections, the
question is, i now grouped the dots and want to select the top
highlighted shape of the body, but if i want to select that, i select the dots
instead of the highlighted shape. Is there an trick to select underlaying objects who are overlapped by other objects?

March 25, 2009 at 8:16 am
You can go Select > Next Object Below, that might work.

Rype

April 6, 2009 at 2:31 am
Hello,
I would appreciate even more, if You could share your secrets how you create multiple transparent gradient strokes as shown in your experiment. Tried but didn’t manage. Any chance…?
Thank you.

Kate

April 27, 2009 at 5:15 pm
you can also use this tool to make double stokes

sheen wells

July 15, 2009 at 11:19 am
nice tuts.

Vicky Khan

August 2, 2009 at 9:31 pm
Mystery work!
Thank you.

Dai Hoang
(VietNam)
Design Wannabe

August 19, 2009 at 3:20 pm

Thanks for all these great tutorials – I learned a lot about Illustrator from these than from any other tutorials !! I hope you could post more !!

Allan De Ramos

August 21, 2009 at 6:02 am

oh yeah. useful useful useful
10x

Madmadman01

August 28, 2009 at 10:43 am

Ah, very helpful. Making friends with the Appearance panel right now!

Ginger

September 2, 2009 at 1:00 am

This is beautiful. :3

Quakeulf

September 4, 2009 at 5:15 am

Thanks to this, I was able to make this:

http://quakeulf2.deviantart.com/art/Visit-the-colonthree-blog-135674178

Great tutorial! :3
Great. I love the way you write your tutorials, they are easy to follow. Keep it up my friend.

---

Merci beaucoup for your very helpful tuts and for sharing your knowledge.

---

this, very thank you.

Your site full professional and very beautiful...

---

Is this working in CS3 too? …or only in CS4…? Cause I just can’t do this kind of “glowing” opacity. It becomes “gray” when it has low opacity. What should I do?

---

Thanks for this one, learned a few new things. Keep up the excellent work.

---

I wonder how I could do this in Flash…
ononja

Greate tutorial, thanks for sharing

standardhype

Fantastic thanks for the tip

Matt89fe

Hi, nice tut!
Could you tell me the name of the font you used here

Rype

It is Klavakia Condensed

Matt89fe

thank you again!!

legalcrash

hello Rype, could we make transparent gradient on CS3? I do not find the opacity options like it has on CS4, thanks
Cool Bi

June 1, 2010 at 7:46 pm
very nice and cool

Reply

Veronica

June 30, 2010 at 5:31 pm
thanks 😊

Reply

chrisfox

July 7, 2010 at 1:44 pm
Thanks man, your tip got me through the day today!

Reply

:S

July 26, 2010 at 4:18 pm
hay 😊 Great tut love it..although i've only got cs3/windows and that make this tut really confusing 😞 do anybody know the same tut but for cs3 instead? that would be really helpful 😊

Reply

somaiah

December 16, 2010 at 4:26 pm
very nice ..thank u a lot!

Reply

Ed

January 27, 2011 at 9:28 pm
Great tutorial!
One problem I'm having is that I want a black background to bring out the colour. I've tried creating a rectangle in he layer behind and also tried creating a fill and converting to shape. What happens then is that all the gradients disappear and I'm left with the white fill of the text.
Any suggestions?

Reply
Thanks for your tut. Good job

Manuel

Wow, This one thing has been my biggest pet peeve with learning illustrator. This tut was amazing, simple, and easy to understand. Thank you So much!!!

Rachel

Trackbacks/Pingbacks

Gradient Strokes in Illustrator | Designschrein
February 18, 2009 at 3:55 am
[...] vectips.com VN:F [1.1.4_465]Rating: 0.0/5 (0 votes cast) Tags: illustrator, tutorial [...]

Best of the Web – February 2009 - VECTORTUTS
February 28, 2009 at 7:00 am
[...] Visit Tutorial [...]

Creative Bookmarks: Best of February 2009 - Tutorial9
March 2, 2009 at 7:30 am
[...] Quick Tutorial: Gradient Strokes [...]

Heads Up Seven Up Blogroll for March 2, 2009 | GrandmasterB dot com
March 2, 2009 at 10:12 am

Creative Bookmarks: Best of February 2009 « artwarriors.com
March 11, 2009 at 9:19 am
[...] Quick Tutorial: Gradient Strokes [...]

30+ Fresh & Useful Adobe Illustrator Tutorials & Neat Tips | Noupe
April 1, 2009 at 3:42 pm
[...] Gradient Strokes [...]

30+ Fresh & Useful Adobe Illustrator Tutorials & Neat Tips | e-szablony.eu
April 2, 2009 at 12:35 am
[...] Gradient Strokes [...]

Gradient Strokes | Foggy Designer
April 2, 2009 at 2:55 pm
[...] Gradient Strokes via Vectips [...]

http://vectips.com/tutorials/quick-tutorial-gradient-strokes/
30 Text Effect Tutorials for Adobe Illustrator | Vandelay Design Blog  
April 19, 2009 at 5:15 pm  
[...] Gradient Strokes [...]  

Heads Up Seven Up Blogroll – March 2 « photoshop tutorials  
July 17, 2009 at 9:25 am  
[...] – 18+ Sources of Inspiration from Coffee, Ink, Blood and other Stains Vectips – Quick Tutorial: Gradient Strokes Blog  
Perfume – Theme: Irresistible For Visually-Rich [...]  

22 Very Useful Adobe Illustrator Tutorials | Web Design Ledger  
July 19, 2009 at 7:21 pm  
[...] Quick Tutorial: Gradient Strokes [...]  

22 Very Useful Adobe Illustrator Tutorials | pc-aras  
July 28, 2009 at 12:52 pm  
[...] Quick Tutorial: Gradient Strokes [...]  

32 Handy Gradient Tutorials Using Photoshop And Illustrator: Part 4 | Graphic and Web Design Blog - Inspiration, Resources and Tools  
July 29, 2009 at 5:46 am  
[...] 13. Quick Tutorial: Gradient Strokes [...]  

Tutorials for Mastering Gradients Using Illustrator | loveillustrator.com  
July 31, 2009 at 3:47 am  
[...] 13. Quick Tutorial: Gradient Strokes [...]  

32 Handy Gradient Tutorials Using Photoshop And Illustrator: Part 4 - Programming Blog  
August 3, 2009 at 4:35 pm  
[...] 13. Quick Tutorial: Gradient Strokes [...]  

The Best Adobe Illustrator Text Effect Tutorials | Creative Nerds  
August 10, 2009 at 11:44 pm  
[...] 2. Quick Tutorial: Gradient Strokes [...]  

» Another Tut — Ellen Flaherty  
August 12, 2009 at 1:38 pm  
[...] These tuts don’t necessarily be silly, but since I’m just running through them hastily to learn some new tricks, I’m not really putting my all into making these into nice designs (maybe I should be?). Here’s a gradient strokes tut. : [...]  

A Lot Of Text Effect Tutorials for Adobe Illustrator | Design resources, Design technology, photoshop, photoshop plugins, photoshop tutorials, illustrator, icons-BENS BLOG  
December 11, 2009 at 12:02 am  
[...] Gradient Strokes [...]  

30+ Fresh & Useful Adobe Illustrator Tutorials & Neat Tips | The Web Design Source  
February 7, 2010 at 4:59 am  
[...] Gradient Strokes [...]  

Gradient Strokes | YourTutorialsBox.com  
March 10, 2010 at 4:19 am  
[...] Click on the picture or here to see the tutorial!!! 0 Comment [...]  

http://vectips.com/tutorials/quick-tutorial-gradient-strokes/  
Page 25 of 26